Simulation crashes on a second computer whereas she runs on a first

Something strange in your ENVI-met? Please post here...
nathphil
Posts: 20
Joined: Wed Oct 02, 2019 7:58 am

Simulation crashes on a second computer whereas she runs on a first

Postby nathphil » Thu Jun 25, 2020 10:25 am

Hi ENVI-Met team,

I've a strange issue with one of my simulation files. I've run a simulation in April on a first PC. The simulation is indeed very, very slow (I think it is not surprising given the size of the huge area and its high resolution...), but it is still working without any problem for the moment.

In order to check if it was possible to go a little faster, I've run exactly the same simulation with the same area on a second computer, whose processor is supposed to be more efficient (Intel I9 vs intel I7 for the first PC). However, the simulation crashes straight away after the initialisation phase ("the temperature,the humidity or the co2 field has become unstable"). Considering that this type of errors can occur randomly, I've rerun three times the simulation, with no success. Every time, it was another grid which was concerned by the instability (neither captured grid nor particular grid, just some ordinary grid that is lost inside a building). All this part concerned the 4.4.4 version.

After having installed the 4.4.5 version of ENVI-Met, I've run the simulation once again. It worked during one hour of simulation and then unfortunately crashed again (started at 6 am and stopped at 7.15 am). But this time, the concerned grid was right in the empty area !

Do you think that it could be a randomly error ? I'm aware that this simumation with a so pretty huge area is "ambitious", but I don't understand why it is working on a PC and not on another, which is supposed to be more powerful and with the same RAM (64 GB)...

In case of need, here are the concerned files : https://we.tl/t-OWXHjbMzHc

Thank you very much in advance for your reply and your patience.

Best regards,

Nathalia

Tim
Posts: 1496
Joined: Mon May 15, 2017 3:46 pm

Re: Simulation crashes on a second computer whereas she runs on a first

Postby Tim » Thu Jun 25, 2020 10:36 am

Hi Nathalia,

Actually we are very much into that topic right now and made a huge amount of test simulations within the last months. Several times we were at the point to say that we finally fixed it since no more of those random crashes occurred. However, other simulations on other PCs then could not show those positive results.
I don't think that it is connected to your model area but I cannot tell you what reason else it might be.
However, we always thought about issues in the code or the compiler but it could also be connected to the processor as you mentioned. We e.g. had several issues on an AMD processor. We will further investigate that now! Thank you very much for the hint.

Best regards,
Tim


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest